Erreur Rails 3.1 Could not find a JavaScript runtime

Après avoir créé votre projet rails 3.1 et essayé de le démarrer, vous obtenez le message d’erreur

/usr/lib/ruby/gems/1.8/gems/execjs-1.2.13/lib/execjs/runtimes.rb :in `autodete
ct’: Could not find a JavaScript runtime. See https://github.com/sstephenson/exe
cjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

Un moyen de le résoudre, est d’ajouter l’appel aux 2 gems suivantes dans votre Gemfile

gem ‘execjs’

gem ‘therubyracer’

Et faire un bundle à partir de la ligne de commande.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.